jump to navigation

Screen Calibration on Ubuntu 12.04 with Spyder2 [workaround] May 6, 2012

Posted by claudio in Uncategorized.
Tags: , , , , , , ,
2 comments

The bad news: the default colour calibration wizard on Ubuntu 12.04 has a bug: awful magenta cast on some screens. Fine on others.

The good news: it works flawlessly using the (graphical) alternative below.

As a enthusiastic photographer (see my latest Perl Fosdem pictures) I am very positive about the colour management integration in the latest Ubuntu (12.04). Sure, colour calibration was possible before, but now it’s an integral part of the system and not a simple add-on. Ubuntu++

Once the reviews are in, I will probably buy the ColorHug open source hardware calibration device. In the meantime I borrowed an old Spyder2 (express) from my father-in-law. I do not recommend buying new devices from Colorvision. The company is known to be very antagonistic to free and open source software. But, if you already have the hardware in a drawer it’s better to use it.

Once you plug in the device, the “Calibration” button will activate and the necessary packages will be installed. However, for this HOWTO it’s easier just to install the software (and its dependencies) from a shell window:

$ sudo apt-get install gnome-color-manager

(This install argyll as a dependency that does the real calibration beneath the GUI.)

This step is only applicable if you have a Spyder 2 device. As mentioned above, the company is not FOSS-friendly and doesn’t even provide technical specifications. You will need the firmware of the device from the Windows driver. If you trust me, you can get mine here [MD5: 007ac5705a3a8ed7edf01569700e6ebf]. Put it in the .local/share/color directory in your home directory (create the needed directories if not present). It was extracted from the 2.3.6 Windows driver for the Spider2 Express (the latest at the time of writing). If you want to create the file yourself, see here. In short: you’ll need the driver CD. If you don’t have it or want/need a more up-to-date version, you’ll need to install the driver and feed the generated .dll to spyd2en: spyd2en -v ./CVSpyder.dll

In the GUI (Dash -> Applications -> Color, or simply type “color” and click the icon), if you select your screen and the “Calibrate…”, the steps offered by the wizard are straight forward. Very easy. While it worked great on the computer of my better half, the generated profile on my own laptop (attached to an external screen) had a terrible magenta cast. Not of the type “your eyes will adapt to it”.

After investigating and looking closely at the profile, it was clear that the profile used a 6500K white balance, instead of the 5000K requested in the wizard (it’s called “Photography and graphics” there). Furthermore, the wizard offered 3 calibrations options: 4, 10 and 20 minutes depending on the desired accuracy. While I chose 4 minutes for testing purposes, the calibration took a long time (an hour or longer). Also, the advanced output in the calibration window (hidden by default) categorised the screen as CRT while it’s a LCD. Because of this, I don’t think the problem is tied to the specific firmware (running the latest available) of the hardware, but rather to gnome-color-manager integration with the device and maybe certain configurations. I don’t have other calibration devices available to test. Bug reported.

dispcalGUI is a OS-agnostic alternative to gnome-color-manager and in fact – just as gnome-color-manager – and GUI on top argyll. Just download the deb (the most recent deb for Ubuntu 11.10 works fine on 12.04). If you double click it, the Ubuntu Software Manager will launch and perform the installation (or just use “dpkg -i” if you are a Debianista at heart).

Now, launch the dispcalGUI application from the Dash or just open a terminal (Ctrl + Alt + t) and type:

$ dispcalgui

Select the Photography profile, your screen (if you have a multi monitor setup) and probe your device (by clicking on the “recycle” arrows) and give your profile a more recognisable name and a location. I use brand_model_calibrationDevice, e.g. Samsung_SyncMaster2443FW_Spyder2Express). Click on Calibrate and Profile and go read a book or take some pictures (it will take a lot longer than 20 minutes, probably an hour). If you wish you can skip the white point and black level, YMMV.

Now go back to the Ubuntu Color Settings as above and add the new created profile by selecting your screen, then click “Add profile”, select other and choose the path you save the monitor profile.

Your monitor is now calibrated!

Adobe Flash missing some mouseclicks November 3, 2009

Posted by claudio in Uncategorized.
Tags: , , ,
4 comments

bugWhile trying to play a flash game with my daughter, I noticed that flash wasn’t working properly on Ubuntu 9.10 on some sites. The fix is trivial, and can be found here.

As Internet posts tend to disappear or move after a while, I copy the fix just in case:

First you need to edit /usr/lib/nspluginwrapper/i386/linux/npviewer file from terminal

gksudo gedit /usr/lib/nspluginwrapper/i386/linux/npviewer

Add the following line before the last line of text

export GDK_NATIVE_WINDOWS=1

Save and exit the file.

Fix for slow virtual desktop switching with Nvidia 96.* and Ubuntu 9.04 August 14, 2009

Posted by claudio in Uncategorized.
Tags: , , , ,
2 comments

nvidiaI have a dual-cpu Sun W2100z workstation I really like. It’s getting rather old, but it’s pretty fast for things like programming and Internet use. Until the release of Ubuntu 9.04, the machne was running fine. After installing the new release it was pretty obvious that the X performance was terrible. Things like glxgears ran fine on this dual screen setup, but things like switching virtual desktops (I use the shortcut ctrl+alt+arrows a lot) took a few seconds when windows were maximized. Sadly, the free driver didn’t work with the 3300 x 1050 resolution I use.

After playing around with the millions switch and config options of the nvidia driver, I found a working setting:

nvidia-settings -a InitialPixmapPlacement=2

To enable this permanently, you can add it to System – Preferences – Startup Applications:

nvidiasettings

(put “nvidia-settings -a InitialPixmapPlacement=2″ (without “”) in the command field).

Bug: Ubuntu 8.10 and older nvidia video cards October 31, 2008

Posted by claudio in Uncategorized.
Tags: , , ,
4 comments

EDIT: Workaround not longer needed as the drives has been fixed on the Ubuntu repositories.

Yeah. New Ubuntu release. Traditionally, this means upgrading without reading the release notes.

<Curse>. This is what it says (I read today):

nVidia “legacy” video support

The 71 and 96 series of proprietary nVidia drivers, as provided by the nvidia-glx-legacy and nvidia-glx packages in Ubuntu 8.04 LTS, are not compatible with the X.Org included in Ubuntu 8.10. Users with the nVidia TNT, TNT2, TNT Ultra, GeForce, GeForce2, GeForce3, and GeForce4 chipsets are affected and will be transitioned on upgrade to the free nv driver instead. This driver does not support 3D acceleration.

Users of other nVidia chipsets that are supported by the 173 or 177 driver series will be transitioned to the nvidia-glx-173 or nvidia-glx-177 package instead. However, unlike drivers 96 and 71, drivers 173 and 177 are only compatible with CPUs that support SSE (e.g. Intel Pentium III, AMD Athlon XP or higher). Systems with older CPUs will also be transitioned to the nv driver on upgrade.

The “nv” driver does not support my dual-monitor 2 x 1680×1050 resolution. After looking for some workarounds (compiling kernels) and at the point of a downgrade to 8.04, I found an easy solution.

(more…)

Dual monitors on Ubuntu 8.04 bug July 6, 2008

Posted by claudio in Uncategorized.
Tags: , , ,
6 comments

Nowadays, the GNOME screen resolution setting allows you to configure multiple screens pretty easy. It seems to work just fine. However, it’s a front-end to the X config an as such it has some problems. In my case, it allows me to clone my main monitor (is that useful to anyone?), but not to extend my desktop over both monitors.

The problem is related to the frontend not passing the errors from the underlying system (xrandr), so you don’t get any hints why it does not work. Maybe my home setup is kind of strange as I use two different resolutions (an LCD 1280×1024 connected though vga and the laptop 1024×768 screen as a second monitor), but still it shouldn’t be that uncommon. I enable the dual monitor setup when useful (gimp), but most of the time I find the different resoltion annoying. At work I use two 1680 x 1050 LCDS.

Anyway, the solution to enable a dual monitor is pretty simple. (more…)

Netbeans tip & tricks: Swing dialogs with the wrong size (same as previous dialog) June 13, 2008

Posted by claudio in Uncategorized.
Tags: , ,
1 comment so far

Netbeans has a killer feature: it’s graphical Swing builder (aka Matisse). It’s fast, flexible and it works. GUI application in no time. Great.

However, when not creating the GUI by hand, it can be difficult to track some bugs. I found out that when using different JDialogs in the same application, resulting in the dialogs having the same size as the first dialog opened. Pretty annoying. This is how to solve it. (more…)

CPAN on Ubuntu fails on bug IO/Uncompress/RawInflate.pm: solution May 30, 2008

Posted by claudio in Uncategorized.
Tags: , , , , ,
13 comments

apt-gettable perl modules on Ubuntu are great. A nice packager at Debian Gnu/Linux compiled the modules and included all dependencies specially for you :) .

This is extremely handy when you are looking for a solution for a programming problem that you know someone else solved before. You apt-get the modules you need and have a quick try.

While doing exactly this (tryng to install HTML::TextToHTML) , I discover CPAN on Ubuntu was broken:” Can’t call method “value” on an undefined value at /usr/share/perl5/IO/Uncompress/RawInflate.pm line 64.”.

I don’t think it’s a Debian/Ubuntu problem, but rather a upstream bug. Some people have the same problem on Windows. How nice the apt-gettable modules are, there are always cases when you need to build modules not yet in the Ubuntu repositories or you need a newer version (both cases here). A non-working CPAN is not acceptable. This is what I did. (more…)

Sun Workstation w2100z and Ubuntu 8.04: no keyboard or mouse May 5, 2008

Posted by claudio in Uncategorized.
Tags: , , ,
add a comment

When upgrading to Ubuntu 8.04 (or when booting with the live disk), my workstation (Sun w2100z) lost the keyboard and mouse (both are usb). Both were present and enabled at boottime (I chose the language and keyboard layout at boot time of the live cd). Luckely, the problem is solved.

(more…)

Microphone on Ubuntu 8.04 on a HP nc6320 laptop April 28, 2008

Posted by claudio in Uncategorized.
Tags: , , , ,
6 comments

There is a bug on the sound setting for my main machine, a HP nc6320 laptop. Everything seems to work fine on GNU/Linux except the microphone.

This is the chipset of my soundcard (in case you have the same problem on an other type of machine):


claudio@brisbane:~$ lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
(more…)

Follow

Get every new post delivered to your Inbox.

Join 145 other followers